Film Scoring with Garageband

A Panda Style Tutorial




Composing a Film Score
to a scene from

Kung Fu Panda
& making it legendary...

As part of our studies on Film Music you get the chance to compose your own score
for the beginning scene from Kung Fu Panda.

Follow the steps outlined in this tutorial to setup your scoring session.
Take note of the tools along the way to help you create an effective film score!

What'’s in this Booklet?

> A Quick Overview of Garageband 2011

- Opening
- Exploring
- Creating
« Exporting

> Project Steps

1. Opening a Film Score Project

2. Saving Project to New Folder

3. Downloading & Importing a Video Track
4. Adding Hit Points for SFX (Foley Stage)
5. Find, Add & Edit Sounds for SFX

6. Adding Background Music via Loops

7. Editing Loops and Regions

8. Adding MIDI, Audio or Voice-Overs

9. Exporting & Presenting

10. Sources & Further Reading
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a New Project

Learn to Play
n Lesson Store
é Magic CarageBand

ﬁ iPhone Ringtone

ﬂi‘ Recent Projects

Movie Arrange Window
Drag'n'Drop clips to here

Kung Fu Panda
Clip already in
> Movies Folder
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Garageband ’11 - An Overview

> Exploring
Play & Record Controls Loop & Metronome
l Buttons l l

LCD Menu controls project properties

Add

New Track L~ Media
- Loop Info

Track Browser Browser

Source your /
SFX if online

add Hit Points m

Pop Out Score Window

AL
Vwrrxal

Movie Track

Once clip has been dragged into the arrange window it
can be viewed in a timeline with a pop out window
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Garageband 11 - An Overview

Musical Podcast > Creating
Buttons  Sounds

Sound Effects
Favorites

Loops First stop
for Sound

Browser Effects (sfx)
Buttons
Just
Click'n'Drag to
arrange

MIDI Tracks are Green MIDI with volume changes

Elec Piano

Audio Tracks are Blue Audio with Panning changes
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Send Movie to iTunes...
Send Ringtone to iTunes
Send Movie to iWeb...
Send Movie to iDVD

Export Movie to Disk...

Burn Song to CD

Export your movie to disk.

Video Settings: | Full Quality B

Use original video resolution. Nothing changes.
Details: 25 frames per second, size: 720 x 404,
audio: AAC, 192kbps, Stereo. Estimated size:
20.1MB.

( Cancel ) ( Export )

( Save As: [Kung Fu Score - Name/Group ] E] )

Garageband ’11 - An Overview

> Exporting

[« » |22 = .m0 | (JGroup/Class/Score Folder 4] Q

¥ DEVICES m /| Kung Fu ...me/Group
I Samuel's Macbook Pro Final 'save as'
&4 Macintosh HD & submission
¥ SHARED - to teacher
= imac = 1

# Archive Project

Saves Real Instrument Apple Loops or a movie into the project so you
can move it to another Mac and continue working.

Compact Project _ Small - 128kbps AAC =

Reduces the size of the project on disk, making it easier to share. Also
reduces audio quality.

BHide extension ( Cancel ) ﬁm )

A
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Project Steps

Each Step will be demonstrated from the IWB by your
teacher but these can help you with staying on task.

Please refer to this video for visual & audio instructions:
http://www.youtube.com/watch?v=yfM238xR2sE

> Opening a Film Score Project

ann

New Project
m Learn to Play
n Lesson Store

é Magic GarageBand

L-L iPhone Ringtone

'iJ‘-' Recent Projects

|__Quit | [ Openan Existing File... | b For Later

> Saving Project to a New Folder

New Project from Template

Save As: Kung Fu Score - Name/Group -
(4 »] 22 = m [ () GarageBand % qQ
B iMac a — [ Amplitube 3 Recording
' New Folder
PLACES
Deskt
{ ElDeskop Name of new folder:
#\ Applicatior
#% admin Group/Class/Score Folder
& Mine
I Documenty _
- =i Cancel Create
L) Downloads — e,
A T
BMwies
SEARCH FOR
Tempo: 2
e 4/4 + | 120 bpm
Key:  C + | | major
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_ Create

+ Open GarageBand
from the Dock

+ Create a >New
Project >Movie

« Once the project has
loaded go to >File
>Save As

- If you are by yourself
or in a group save the
file as >Kung Fu
Score_Name/Group
so it can be handed in
and marked later

- Save the project in a
new folder of the
same name (this is
where you will put the
movie clip)
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Croup/Class/Score Folder

> Downloading & Importing a Video Track

- If your movie clip is on
a school server or
online, download it
and move it to your

M Film Cuts groups project folder
(as above)

- If the movie clip is
already in your

- 2:39 >Home >Movies
S — Folder you will see it

in the Media Browser

of GarageBand (Left)

- Drag the movie clip to
the Movie Arrange

Movie Arrange Window Window either from:
Drag'n'Drop clips to here

> Media Browser Pane
> Group Project Folder

+ GarageBand will
automatically map the
scene changes to a
timeline and adds a
detachable video
window. Press Play
and see!
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Project Steps

Please refer to this video for Foley Stage Effects:
http://vimeo.com/11436985

> Adding Hit Points for SFX

Source your
SFX if online

add Hit Points

Undo Create Track ¥z
Redo 3827
Cut

Copy A 38C
Paste ' Y
Delete

Delete and Move N &
Select All #A
Add Marker @,
Split $T
Join 38)

Add To Loop Library

Special Characters... T
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Don't
forget
the
simple
creation
tools of
cutting
and
pasting
+

hit 'p'
for hit
points

Once you clip has been loaded and
you have SAVED your project

complete the following steps:

4.

6.

. Watch the clip taking note of key

moments that will require a Foley
Stage Sound Effect (SFX)

. On the second time you watch the

clip hit >P every time you see that
important SFX moment (e.g. coin

dropping)

. Hit Points will help you gather

sounds for a particular moment in
the clip

You are to then search through
GarageBand’s sound effects and
using your knowledge of sound
editing make them fit into each hit
point

. If you want more sounds visit your

>Applications folder where you
should find installed Sound
Librarian. >Open this and >Search
for the sounds you want

Once you have downloaded the
sounds drag them into your group
folder befare importing them to the
Movie Arrange Window

* Sound Librarian URL is where you
can install the software for your OS
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> Find, Add & Edit Sounds for SFX

Musical Podcast
Buttons . Sounds

Loops

Browser

Buttons - Located at the top right hand side of
GarageBand when you hit > Loop
Browser Button (bottom ‘eye’)

» Depending on the Jam Packs installed
you may have more or less samples

« There are many many sound effects in
GarageBand, just drag’n’drop them onto
the Movie Arrange Window to add them
near your Hit Points BRGS0

- Some will require editing so use the Track ingles »  Ambience (14)
Editor Button to do this (below) '

- If you drag sound effects from Sound
Librarian use the Track Editor to edit them
too

Effects

First stop
for Sound
Effects (sfx)

Add

Just

Click'n'Drag to
arrange
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MIDI Tracks are Green MIDI with volume changes

Elec Piano

T

O_J:- Back Fiip beat 01

Audio Tracks are Blue Audio with Panning changes

2-5tep Back Flip Beat 01 |{

Add
New Track

« You can edit any track in GarageBand, using the Track Edit Button and by remembering what
Blue or Green represents (also Orange/Purple for later).

- As seen above you can edit the actual notes of MIDI files if they are green OR you can cut and
paste the Blue Audio Wave files

« In the Left Hand track views you can also graphically alter the tracks Volume or Panning

- Using your past experience in the Blues Compositions make the loops fit the action using the
timeline

2-Step Ahead Piano 01 [»]
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> Adding Background Music Via Loops
> Editing Loops & Regions
> Adding MIDI, Audio & Voice-Overs

Chapters Six, Seven & Eight are rolled under the heading of
ldeas & Ways to Compose

+ Once you have added in and edited all the sound effects you nominated via hit points start
to decide what musical effect you would like to create with your score.

a) Oriental?

b) Indian?

c) Dance Vibe?

d) Rock

e) Orchestral

@ Use the loops button to search for suitable loops
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+ Adding Loops are up to your personal preference but remember they need to fit the
action and the sound effects need to be heard clearly (use the graphic volume editor)
« Try to stick to a single style and not change loops quickly. You are trying to create a

background atmosphere

- Some Loops contain sound effects that can be copied and pasted for action scenes

All Effects

Jingles

Stingers
Sound Effects

Favorites

All Effects (229)
Cinematic (24)
Country (9)
Electronic (25)

Jazz (30)

SEREEEEEEEESE

Loops can be added to
the arrange window by clicking
and dragging. Then use the loop
caret or extending caret to edit
the loop.

Contemplative Synth 02
Contemplative Synth 03
Contemplative Synth 04
Contemplative Synth 06
Crowd Applause 01
Crowd Applause 02
Crowd Sound Effect 01

Crowd Sound Effect 02

oo W oo

D W W w NN A
~

Dramatic Accent 01
Elysium Long
Elysium Medium
Elysium Short
Investigation Long
Investigation Medium
Investigation Short

Lounge Vibes 02

Orchestral (51)
Rock/Blues (55)
Urban (20)

World (15)

»  Jingles contain
complete musical tracks
that you can edit or use
directly for background
music

Carousel
Dolce Vita
Celato
[aEVELE!
Island Long
Island Medium
Island Short
Jaracanda
Lotus
Sanskrit
Shetland
Shogun
Tigris
Travel

Vino

Tracks

« As you start to edit the loops length,
panning, volume and tuning, try using the

. y v ~ .ﬂ :
Groove Track feature if you have a Drum x - '

Track or Jingle going through the film clip.
This locks all tracks in-time to it!

NG

Click to set this track as the groove track.

Film Music Scoring Task - Panda Style




Editing Options include:

a) Piano Roll Editor for MIDI (green loops)

b) Flex Time editing for AUDIO (blue loops)

c) As well as adding effects in the Track Info
Window >Edit

Below are two of the same sections taken from an audio loop.

The left hand involves pulling the audio wave to the end of the bar, the right hand
involves pulling it back to the start of the bar. This can now be accomplished in
GarageBand 2011.
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> Adding MIDI & AUDIO Files

a) You could add a MIDI file that you find on the internet of some Chinese
Folk Music for example, drag it into your movie arrange window and it will
turn into a Green MIDI Loop for editing

Get some traditional Chinese MIDI files here:
http://faculty.pittstate.edu/~yliu/music/Mchinese.html

b) You could buy from iTunes Kung Fu Fighting, import the track into
GarageBand for editing and it would turn into an Orange Audio track to add
to your Score (notice mine are purple, its a secret)

The MIDI File contained three tracks so GarageBand added them all

<+ Pop Flute

@

& Pop Flute

Ll

<& Pop Flute

<

Rain SFX
Thunder SFX

Kung Fu Fighting

Kung Fu Fighting El
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> Adding Voice-Overs

Once you have added your SFX, made some background
music and edited your own tracks here comes the most fun!

Watch on YouTube the original opening for Kung Fu Panda and take note of the
spoken dialogue, “There is no price for awesomeness.”

Either re-create the dialogue or add your own using the following easy steps.

1. Create a Real Instrument Track from >Track >New Track

2. Make sure you use headphones to listen to your composition

3. Turn Off monitoring to prevent feedback and sound leaking from your computer to
the recording of the voice

4. Try to find a quite time in the room or at recess because now you hit the big red
record button and speak in the new dialogue (it will show up in the arrange
window as an audio wave)

5. Finally, once it is recorded try to add some vocal effects using the Track Info
button >Vocals>Deeper Vocals etc.

Software Instrument Real Instrument Electric Guitar

For Instrument sounds created by For audio recordings such as voice, For audio recordings of electric guitar
CarageBand and playable using a guitar, bass, or any instrument that can using built-in GarageBand amps and
USB, MIDI, or onscreen keyboard. be captured by a microphone. stompbox effects.

- For all kinds of instrument sounds

) from the computer's library (_Cancel ) (_Create )

Basic Track > Deeper V

Bass » Epic D

Drums L Female Basic
Female Danc
Female RnB V

Vocals Female Rock Vocals

Gospel Choir
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At last you have a working film score with SFX, background
music, audio and maybe even a clever voice-over. What next?

1. Go through and adjust all the levels of the sounds (volume,

panning etc) so that each sound and effect blends nicely to
the next

2. When all is awesome! Go to Share > Export Movie to Disk...

Export your movie to disk.

Video Settings: | Full Quality )

ar
R

Use original video resolution. Nothing changes.
Details: 25 frames per second, size: 720 x 404,
audio: AAC, 192kbps, Stereo. Estimated size:
20.1MB.

Exporting & Presenting

Send Movie to iTunes...
Send Ringtone to iTunes
Send Movie to iWeb...
Send Movie to iDVD

Export Movie to Disk...

Burn Song to CD

3. Choose Full Quality for Video
Settings
4. Save to your Project Folder

Submit your Legendary Score!

Save As: Kung Fu Score - Name/Group

@ )

| )

< » !/

oo
oo

] | () Group/Class/Score Folder

¥ @

1 ¥ DEVICES m Kung Fu
I samuel's Macbook Pro
&d Macintosh HD

¥ SHARED

A
= iMac 3

me/Group

E Archive Project

Saves Real Instrument Apple Loops or a movie into the project so you
can move it to another Mac and continue working.

Compact Project

Small - 128kbps AAC

Reduces the size of the project on disk, making it easier to share. Also

Group/Class/Score Folder reduces audio quality.

# Hide extension ( New Folder )

( Cancel ) ( Save )
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> Sources %

Images Used in Publication from own library, screenshots or
free icons collection. Kung Fu Panda images sourced below:

http://akminerva.files.wordpress.com/
2010/03/2008_kung_fu_panda_002.jpg

http://www.canmag.com/images/front/movies2008/
kungfupand

kunq fu nandaz Jpg

http://3.bp.blogspot.com/ HMKIVc7rvPw/SL6Fo1rz1dlI/AAAAAAAAAEC/
xSRROVDiaaY/S1600-R/Kung-Fu-Panda-Wii-01.jpg

> Further Reading

Garageband Online Sources

http://garageband.maccreate.com/category/tutorials/

http://ww
itunes/

http://www.synthtopia.com/Articles/GaragebandTips.html

http://www.thegaragedoor.com/index.html

https://stucomp.stanford.edu/garageband _music_tutorial

http://en.wikiversity.org/wiki/LessonPage:Film_scoring_for musicians:Spotting_Session

> Want to make Examinations with GarageBand?

http://wrightstuffmusic.com/2009/06/19/exam-time-in-garageband/
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